PLEASE READ: Malibu Racing Lives!!

electric cooling fans stopped working

Park your car and talk with other G-Body owners about automotive related topics.

Moderator: Moderators

Post Reply
User avatar
DOUG213XRJ
MalibuRacing Junkie
Posts: 4643
Joined: Mon Sep 18, 2006 8:26 pm
Location: West, MI

electric cooling fans stopped working

Post by DOUG213XRJ » Thu Aug 29, 2019 6:15 pm

I took the 81 Malibu to a street cruise and after a few laps the Malibu started running about 5 to 10 degrees hotter then last few laps. We pulled in to a gas station after getting some fuel, I popped the hood and found one of the fans stopped working. I was checking the relays (not sure which relay runs which fan)and the last fan would stop and start every time I would wiggle the 12volt wire coming from the fuse box. A few minutes down the road the last fan stop working . Hurry up and got on the highway. Made it home with no fans. The first fan stopped because the wire from the 12 volt wire coming from fuse box to the relay got disconnected . Not sure why the other fan stopped working. The next day after I plugged the wire back in to the fuse box both fans work fine. So my problem is why did the other fan stop working, can the relay get hot enough to stop power to the fan, or is there something Im missing ? all the fuses and switch are good. Each fan runs its owe relay, battery power, fuse, ground and 12 volt power from separate fuse box plugs. the only thing the fans share is the switch.

Thanks Doug
1978 El camino
1981 Malibu SS

Post Reply