Blown Head Gasket?

thumper

Weekend Racer
Jul 11, 2012
63
0
0
Phoenix, AZ
I bought a used 454 and put it in my monte.

At first it would not start and almost all the cylinders did not have compression, even tho it was sold to me compression tested (took their word for it).

Pulled passenger head and put oil in cylinders, now compression.

Got the car running and no compression in #3, 5 and 7. Thought maybe I could drive in and see if the rings were stuck.

Car runs hot.

Now the car has a brand new f-body radiator, mark vii fan and newer thermostat (feels like it opens on hoses).

Exhaust temps is 300 degrees lower on the #3, 5 and 7 cylinder.

Car sucks and spits water up threw radiator when idling.

Today I warmed car up, rechecked timing and drove 1/2 mile (25 mins running time total) car was at 240 degrees.

Do you think I should just pull the drivers head and see if the gasket is blown? I am feeling that is maybe something but don't want to jump ahead of myself. Passenger side, I did not see anything wrong with gasket, head, cylinder or piston but replaced the gasket.

Thought about ordering Robertshaw thermostat but I think it may help but is not the problem.

Engine is used 80's 454 with a performer cam and summit intake.
 

bracketchev1221

Dragway Regular
Apr 22, 2009
1,111
0
0
Mountville Pa
Its got no compression and water is spitting out of the radiator, you have no choice but to pull the head.
 

thumper

Weekend Racer
Jul 11, 2012
63
0
0
Phoenix, AZ
I pulled the head this morning. It all looked good piston, gasket, walls and valves. I would not think there was a problem as the head gasket and sealing surface didn't look like anything was not right. Only thing is I saw the 3 low cylinders were a tad damp on the cylinder. The carbon was not done dry like cylinder one. It was soaked but damp enough to smear on your finger.

I am thinking I may just put a new gasket on and see what happens. I had good luck on the passenger side.
 

thumper

Weekend Racer
Jul 11, 2012
63
0
0
Phoenix, AZ
Put it all back together and now all the cylinders are firing.


Still runs a little hot 240-250. I put a new f-body radiator in it with a new high flow 185 t-stat.

Do you think going to this radiator would help or is it close to the f body radiator. I have a Mark VII fan on it with nothing blocking airflow.


I am going to recheck for air pockets

Base timing is like 12 degrees

I live in Phoenix, so the 70 it is now isn't nothing to the 110 it will be in the summer.
 
Last edited by a moderator:

thumper

Weekend Racer
Jul 11, 2012
63
0
0
Phoenix, AZ

Or this one.
 
Last edited by a moderator: