Electrical Issues

richamer1

Frequent Racer
Oct 17, 2004
520
0
16
New Carlisle, Oh
Have 2 maybe related. Car shut off going 45 I have no spark. Need to trouble shhot that have 12V+ at Batt term on HEI dist. It is a Mallory with a Mallory Coil and cap. Put another coil and cap on nothing. I have the original HEI dist. I can put in but wanted to trouble shoot a little before just replacing parts. Second issue when I tried to restart the car it continued to crank after I turned off the key until I turned off the battery disconnect switch. Battery in truck , Battery disconnect under back bumper, Ford solenoid under hood with purple wire on S terminal. For some reason solenoid seems to latch. If I remove battery side of solenoid and put it back down car will stop cranking until I turn the key again will crank I can remove purple wire and car will continue to crank. It has worked fine for years. I replaced auto column with a manual one. I do not have a switch on the clutch pedal. and no jumper across connector. Must be a N/O switch. Just looking for a few things to check never felt the need for a CSS but maybe it is causing some issue not sure. Thanks
 

richamer1

Frequent Racer
Oct 17, 2004
520
0
16
New Carlisle, Oh
t5montecarlo said:
spark shutting off while driving can point to the HEI module. Some parts stores can test them, but if you have 2, you can try replacing it and see if you found your trouble.
It was the HEI module the one that went bad was a couple years old Mallory lest than 1500 miles the one I put on it that worked was 34 years old and probably close to 200K off my old 267. Some better than others ?
 

t5montecarlo

MalibuRacing Junkie
Oct 21, 2007
4,380
2
38
Lederach
garage-scene.com
I think the answer is "yes".

I don't know what causes them to fail, but heat may be a factor. I think there should also be some special heat sync paste between the module and the housing, which I assume helps to dissipate heat to the housing.
 

LS6 Tommy

MalibuRacing Junkie
May 15, 2004
15,848
0
36
North Jersey
I wouldn't use a Mallory ignition part on a lawn mower...

Tommy