Proper way to install the new speedometer cable core.

78elk

Dragway Regular
Thread starter
Mar 6, 2014
1,261
79
48
Mountain Home Id
The cruise control worked great. The issue was the speedometer wasn't working properly. I changed the VSS on the cruise control and put more lubrication around the speedometer cable. It's working now like it should.
 

78elk

Dragway Regular
Thread starter
Mar 6, 2014
1,261
79
48
Mountain Home Id
I don't think the VSS was bad from the point that it registered the speed correctly for the cruise control. I questioned how good drive parts were inside of it's. After I spoke with Rostra cruise control technical department , I was told that thoare made of metal now, and mine was made from plastic. It could have been the old VSS or not enough lubrication on the speedometer cable. Maybe it was both.
 

MalibuRacing.com Gear

Stickers & Shirts!!

Quick Navigation

User Menu

Credits

© 2001-2022, All Rights Reserved.
Ripp Technical Services
A ForumGeeks Production.

MalibuRacing.com is a place to provide and exchange performance tech, tips, information and general discussion about the 1978-1983 Malibu and Malibu Classic. All A/G body fans and discussions are welcome here. Much of the information on this site applies to other years and models of the A/G body lineup.

Malibu Racing is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com. Amazon, the Amazon logo, AmazonSupply, and the AmazonSupply logo are trademarks of Amazon.com, Inc. or its affiliates.